标题: vps升级linux内核随记

时间: 2014-05-17 19:23:51

正文:

想折腾折腾比较时髦的 docker , 由于有内核版本要求, 至少 3.2 推荐 3.8 , 发现 budgetvm 的 OpenVZ 的 VPS 是 ubuntu 12.04 , 内核版本 2.6.32 ! 对内核相关不怎么了解, 而搜到很多文章 12.04 LTS 应该是 3.2 内核, 估摸着大概是被手工切换,也就是降级使用 2.6 内核了?

        转载请注明出处 http://blog.hickwu.com/posts/329 by Hick

尝试按照搜索资料升级:

sudo apt-get update
sudo apt-get upgrade

sudo apt-get install linux-image-generic-lts-raring linux-headers-generic-lts-raring

结果提示的错误看不大明白, 搜索无果(省略了部分):

dpkg: dependency problems prevent configuration of linux-image-generic-lts-raring:
 linux-image-generic-lts-raring depends on linux-image-3.8.0-39-generic; however:
  Package linux-image-3.8.0-39-generic is not configured yet.
dpkg: error processing linux-image-generic-lts-raring (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 linux-image-3.8.0-39-generic
 linux-image-generic-lts-raring
E: Sub-process /usr/bin/dpkg returned an error code (1)

大概了解是因为安装了多个内核, 很多解决方法是提示删除, 于是类似这样的删除能解决部分错误, 但是最终还是无法升级, reboot 多次无果:

 sudo apt-get remove --purge linux-image-3.8.0-39-generic 

注意该命令可以查看当前安装的 linux 内核的情况, 如果上面的命令不带 --purge , 则状态可能显示为 deinstall , 没有彻底删除:

root@webrube:/var/www# dpkg --get-selections | grep linux-image
linux-image-3.2.0-61-generic                    install
linux-image-3.5.0-49-generic                    deinstall
linux-image-3.8.0-25-generic                    deinstall
linux-image-3.8.0-39-generic                    deinstall

好歹算是学到了些东西, 不枉我一番瞎折腾.

后来更换关键字搜索, 类似 vps upgrade kernel 一类的, 发现有说法说 vps 的内核可能是跟其所属主机相关的? 意味着 vps 的内核是跟主机共享的, 单个 vps 是没法单独升级的? 有些 vps 提供商可以在控制面板选择升级内核, 跑到我的 vps 服务商 budgetvm 一看, 还真没这个操作, 倒是可以选择其他版本的 os . 顺便看了ubuntu 提供多个版本选择, 到官方查了, 12.04 和 14.04 官方支持的时间很长, 貌似跟 linux 内核版本类似, 主版本号偶数的才是稳定长期支持的版本, 13.X 就不推荐作为长远考虑去使用了, 难怪之前看到很多文章都是 12.04 的, 14.04 今年初才出来.

于是乎, 最终升级 kernel 的事, 还是得去问 vps 服务商了.

查看更多文章
分享到:


分享到: